S4 HANA conversion SUM error related to Schema SAP_ECC

Hi,

During S4 Hana conversion SUM sometimes give following error.

SUM%20error

SUM error

In log file system was stuck at following place.

SAPup> Starting subprocess with PID 26421 at 20211104101611
ENV: DIR_LIBRARY=/usr/sap/PRD/SUM/abap/bin
ENV: LD_LIBRARY_PATH=/usr/sap/PRD/SUM/abap/bin:/usr/sap/PRD/SYS/exe/run:/usr/sap/PRD/SYS/exe/uc/linuxx86_64:/usr/sap/PRD/hdbclient
ENV: PATH=/usr/sap/PRD/SUM/abap/bin:/home/prdadm/bin:/bin:/usr/bin:/sbin:/usr/sbin:/usr/local/bin:/usr/sap/PRD/SYS/exe/uc/linuxx86_64:/usr/sap/PRD/SYS/exe/run:/home/prdadm:.:/usr/sap/PRD/hdbclient
ENV: RSEC_SSFS_DATAPATH=/usr/sap/PRD/SYS/global/security/rsecssfs/data
ENV: RSEC_SSFS_KEYPATH=/usr/sap/PRD/SYS/global/security/rsecssfs/key
ENV: SAPSYSTEMNAME=PRD
ENV: dbms_type=HDB
*DBENV: dbs_hdb_schema=SAPABAP1
ENV: rsdb_ssfs_connect=0
*DBENV: (auth_shadow_upgrade)
PWD: /usr/sap/PRD/SUM/abap/tmp

EXECUTING /usr/sap/PRD/SUM/abap/bin/SAPCAR -cvrf /usr/sap/PRD/SUM/abap/log/SAPup_troubleticket.sar -C /usr/sap/PRD/SUM/abap -A /usr/sap/PRD/SUM/abap/tmp/REPORT_FILES.LST -T /usr/sap/PRD/SUM/abap/tmp/RENLOGS.LST
a doc/analysis/SAPupPhaseList.xsl
a doc/analysis/UPGANA.XML
a doc/analysis/UpgAnalysis.xsl
a doc/analysis/phaselist.xml
a log/CHECKPROF_INI.LOG
a log/CHECKS.LOG
a log/CHECKS.SAV
a log/ENVDUMP.LOG
a log/PHASES.LOG
a log/PHASES.SAV
a log/SAPUPPHASES.LOG
a log/SAPup.ECO
a log/SAPup.log
a log/SAPupConsole.log
a log/SAPupFeatures.log
a log/SAPupStat.log
a log/SAPup_troubleticket.log
a log/TOOLVERS.SAV
a mem/CHECKS.DAT
a mem/COMPINFO.DMP
a mem/EHPSTACK_COMPONENTS.DMP
a mem/HDBDESTCOMP.DMP
a mem/INSTANCELIST.DAT
a mem/MEMBUFFSAPup.dat
a mem/MEMDBSAPup.dat
a mem/MEMFileSAPup.dat
a mem/MEMProcSAPup.dat
a mem/MEMSAPup.dat
a mem/NAVERSCURR.DMP
a mem/TAIATRPRE.DAT
a srv/SAPupHttp.log
a srv/SAPup_sumabap.out
a sumabap.mf
a trc/CDTRACE.trc
a trc/HDB.trc
a trc/TOOLVERS.trc

The reason for this issue was missing schema SAP_ECC.

Solution:

If SAP_ECC schema is not listed, you will need to open SAP Hana Studio in Modeler perspective and in the Quick View tab choose Schema Mapping, then add SAP_ECC to point to the correct physical schema.

I have add the schema as below.

Schema%20Mapping

Schema Mapping

This will resolve the issue.

For more info please follow S/4 HANA Topic.