SAP Business Connector 4.8.1 Upgrade

Hello All,

SAP business connector 4.8 is only supported until December 31, 2021, as per SAP NOTE 3059522. if your environment is running on SAP BC 4.8 you have to upgrade to 4.8.1.

The upgrade of SAP BC 4.8.1 is very simple, only we have to make sure all prerequisites are fulfilled.

Pre-Requisites (General):

Hardware requirements

Supported OS

Software requirements

Physical Memory: 4 GB minimum, 8 GB recommended

Windows X64

Any recent version of Microsoft Internet Explorer or Mozilla Firefox.

Free disc space: 250 MB minimum

Linux X64

CPU: Intel Core i3 or equivalent

AIX

SAP BC 4.8.1 is supported with JVM 8.

List of Support OS:

  • Windows 10, Windows Server 2012, Windows Server 2012 R2, Windows Server 2016, and Windows Server 2019 on x64 (64bit)
  • Linux (SuSE SLES 11, 12, and 15 and RedHat RHEL 6, 7, and 8) on x86_64 (64bit)
  • AIX 7.1 and 7.2 on PowerPC (64bit)

There are a few major changes in SAP BC 4.8.1.

  • 64-bit OS only supported for SAP BC 4.8.1.
  • SSL 128 bit is only available, 56 bit is no longer available.
  • HP-UX and SunOS not supported to run SAP BC 4.8.1
  • The installer is a Java Archive file (jar) for all operating systems.

Please refer to Note: 1094412 for Release, Supported OS version/flavors, and restrictions for SAP BC 4.8.

To check pre-requisite and download the SAP Business Connector Click Here

If any of the above-mentioned prerequisites are not met, installation or upgrade to 4.8.1 is not possible.

Now we have a good idea about SAPBC 4.8.1 and its prerequisites So, Let’s dig in.

There are two methods to upgrade to 4.8.1.

Method1: in-place upgrade, useful if source and target OS are equal and supported for 4.8.1.

Method2: Export & import (backup restore), if source and target OS are not equal. also, useful for migration scenarios.

Upgrade on LINUX:

Prerequisites : (Linux only)

  • C++ Runtime 6.0 (libstdc++.so.6) is required – SAP Note 1021236 for instructions. or run below command to install
    • zypper install glibc  — for SLES
    • yum in glibc — for RHEL
    • check whether libstdc++.so.6 installed by command :- rpm -qa ibstdc++6*
      libstdc++.so.6%20is%20available%20in%20the%20system
  • JAVA/JDK is required, follow the instruction for installing and checking java is installed.
    • zypper install java — for SLES
    • yum in java — RHEL
    • type “java -version” without quotes with root user to check java is installed.
    • JAVA%20Version
  • /tmp should have at least 350 MB free space for smooth installation
  • Host entry in /etc/hosts file

My Source is SLES 12 SP4, SAP BC 4.8, and JVM 5

  • Check the current version of SAP BC and JVM using the about tab of the portal

SAP%20BC%204.8

SAP BC 4.8

  • If you have installed your BC 4.6 / 4.7 on an OS which is supported by BC 4.8.1, you can proceed as follows:

My Target will be SLES 12 SP4, SAP BC 4.8.1, and JVM 8

  • Shutdown the old BC.
  • Backup your whole existing BC directory.
  • Deinstall SAP BC 4.8 (this will keep files which have been created/modified after installation, meaning it will keep your config changes and your packages!).

Run command “java -cp uninstaller.jar uninstall -i console” without quotes.

  • follow the instruction and finish the uninstallation.
  • The uninstallation deletes all files originally installed by the SAP BC installer, but not files that were created afterwards, like configuration files, custom packages and patches/updates that were installed at a later time. While we want to keep the configuration and custom packages, so that the upgraded SAP BC continues to work identically to the old one, we need to get rid of later patches, as they are no longer needed for the 4.8.1 version and might interfere with the new code of that version. Therefore, after the uninstallation please delete the following files and directories under the \Server directory manually. (Note: depending on the patches, CoreFixes and ServiceReleases that have been installed on this BC in its lifetime, not all of these directories may exist.)
  •  jvm
  • updates
  • packages/SAP/code
  • packages/SAP/ns
  • packages/WmDB/code
  • packages/WmDB/ns
  • packages/WmPartners/code
  • packages/WmPartners/ns
  • packages/WmPublic/code
  • packages/WmPublic/ns
  • packages/WmRoot/code
  • packages/WmRoot/ns and if one of the following packages is installed:
  • packages/WmSamples/code
  • packages/WmSamples/ns
  • packages/WmWin32/code
  •  packages/WmWin32/ns
  • Important: Do not delete any other files and directories that are left in the 4.8 Server directory. Those files contain important user-created and configuration data.
  • Do NOT delete this BC directory; do not delete left-over configuration files in it!

Install the new BC 4.8.1 version into the same/old SAP BC 4.8 directory.

  • unzip the downloaded BC 4.8.1
  • Install BC 4.8.1 “java -jar setupBCServer.linux64.jar -console -logfile bc481-serverinstall.log” without quotes.I am using console mode for installation there 3 modes of installation.
  • Make sure provide the path of old SAP BC installed directory for new installation.
  • follow screen instruction and complete the installation.
  • Check if you have made some changes to bin/server.bat or server.sh in your old BC. If yes, reapply these changes (except JDK-settings!) for 4.8.1. in my case, nothing was changed.
  • Start the new BC.
  • Check the current version of SAP BC post installation.
  • the upgrade is successfully completed.
  • Apply hotfix patches if applicable. I am applying Business Connector 4.8.1 Hotfix 1 (SR0)For installation instructions see SAP Note 3096151.
  • disable SAP package. Package > Management > disable SAP
  • Restart SAP BC.
  • Download BC481SR0HF_1.zip and copy to <sapbc>/replicate/inbound
  • open package >management > Install Inbound Releases
  • select BC481SR0HF_1-20007203.ZIP and Make sure that the checkbox “Activate upon installation” is not marked..
  • Click on the Install Release button. 
  • Restart SAP BC Again.
  • Go to “Packages –> Management” and activate the SAP package.
  • If installation was successful, the overview page of the SAP package (“Packages –> Management –> SAP”) should now show the line
    “HotFix 1 for SAP Package SR0 (Escape sequences in IDoc XML and duplicate response header fields in XML Transport)”
    under “Patch History”.
  • Hot Fix was installed successfully. currently, only one hotfix is there, please check for the hotfixes at the time of installation.
  • When starting, the BC will now automatically load all existing config files (they are compatible between 4.8 – 4.8.1) and packages.
  • Check if any packages could not be loaded successfully
  • Recommendation:
  • Take full backup after a successful upgrade.
  • The packages currently used for ELSTER (ETNotif, ETStmt, and ELStAM – ELSTER_EXT 5.4) and ZfA/RBM can still be used on SAP Business Connector 4.8.1. as per SNOTE:3059522
  • If you are using the SAP BC for Elster: delete the ELSTER_EXT package except for
    the config directory. Then, after the upgrade to 4.8.1, you can install the latest
    ELSTER_EXT 6.x package using the “simplified” installation process.